• Company Number: 00357 22 356840
FREE SHIPPING FOR ALL ORDERS OF  €100
  • Contact Us
  • Company Number: 00357 22 356840
Select category
  • Select category
  • ACCESSORIES
    • ADAPTORS
    • ALKALINE BATTERIES
    • CABLES
    • CALCULATORS
    • CARRYING CASES
    • DOCKING STATIONS & PORT REPLICATORS
    • EARPHONES & HEADPHONES
    • JOYSTICKS
    • KEYBOARD & MOUSE SETS
    • KEYBOARDS
    • MOUSE
    • OPTIONS FOR LAPTOPS
    • OPTIONS FOR PCS
    • OPTIONS FOR PRINTERS
    • OPTIONS FOR WHITEGOODS
    • OTHER ACCESSORIES
    • PEN
    • POINTERS & ADAPTERS
    • POWER BANK
    • SOUNDBARS
      • SPEAKERS
    • SOUNDBARS / SPEAKERS
    • TV TUNERS & RADIO CARDS
    • WEB CAMERAS
  • ADAPTORS, CABLES & USB HUBS
    • AC ADAPTORS
    • ADAPTORS
    • CABLES
    • USB HUBS
  • AIR CONDITIONING
    • A/C 12 BTU IN DOOR UNIT
    • A/C 12 BTU OUT DOOR UNIT
    • A/C 18 BTU IN DOOR UNIT
    • A/C 18 BTU OUT DOOR UNIT
    • A/C 24 BTU OUT DOOR UNIT
    • A/C 24 BTU IN DOOR UNIT
    • A/C 9 BTU IN DOOR UNIT
    • A/C 9 BTU OUT DOOR UNIT
    • AC REMOTE CONTROL
    • OPTIONS FOR A/C
    • OTHER ACCESSORIES
  • AUDIO – VIDEO
    • SOUNDBARS
      • SPEAKERS
    • SOUNDBARS / SPEAKERS
  • COMPONENTS FOR PCS & SERVERS
    • CONTROLLERS
    • CPUs
    • DVD – RW DRIVES
    • DVD DRIVES
    • ETHERNET CARDS
    • GRAPHICS CARDS
    • HARD DISK DRIVES
    • INTERNAL SSD DRIVES
    • MEMORY MODULES
    • OPTIONS FOR SERVERS & RACKS
    • POWER SUPPLIES
    • SOFTWARE OPERATING SYSTEM
  • CONSUMABLES
    • DATA TAPES
    • INK BOTTLES
    • INK CARTRIDGES
    • INK CARTRIDGES MULTIPACK
    • MAINTENANCE BOX
    • PAPER
    • PRINTHEADS
    • TONER CARTIRDGES MULTIPACK
    • TONERS CARTRIDGES & DRUM UNITS
  • COPIERS
    • COPIERS
    • OPTIONS FOR COPIERS
  • GAMING
  • HOUSEHOLD GOODS
    • BREAKFAST
    • COFFEE
    • COOKING
    • MICROWAVES
    • OPTIONS FOR HOUSEHOLD GOODS
    • PERSONAL CARE
    • STEAM IRON
    • VACUUM CLEANERS
  • MONITORS
    • 20-24" MONITORS
    • 25-30" MONITORS
    • 32-49" MONITORS
    • LFDs DIGITAL – SIGNAGE
    • MOBILE MONITORS
    • OPTIONS FOR MONITORS
  • NETWORKING & UPS
    • ACCESS POINTS
    • ANTENNAS
    • BATTERIES
    • ETHERNET CARDS
    • FAX MODEMS
    • INTELLIGENT BUILDING
    • IP PHONES
    • KVM SWITCH
    • LAN SWITCHES
    • OPTIONS FOR NETWORK
    • POWERLINE
    • RACK CABINETS
    • ROUTERS
    • TRANCEIVERS
    • TV TUNERS & RADIO CARDS
    • UPS
    • USB HUBS
    • Wi-Fi MESH SYSTEM
    • WI-FI RANGE EXTENDER
    • WIRELESS ADAPTERS
  • NOTEBOOKS
    • 10-14" NOTEBOOKS
    • 15-16" NOTEBOOKS
    • 17-18" NOTEBOOKS
    • BATTERIES
    • DOCKING STATIONS & PORT REPLICATORS
    • OPTIONS FOR LAPTOPS
    • WORKSTATIONS LAPTOPS
  • PCs
    • ALL IN ONE PCS
    • MINI & SFF PCS
    • OPTIONS FOR PCS
    • PCs
    • WORKSTATIONS PCS
  • PHOTOGRAPHY – DIGITAL CAMERAS
    • BATTERIES
    • DIGITAL CAMERAS
    • LENSES
    • OPTIONS FOR CAMERAS
  • POS SYSTEMS
    • OPTIONS FOR POS
    • POS PRINTERS
  • PRINTERS & SCANNERS
    • ALL IN ONE INKJET PRINTERS COLOUR
    • ALL IN ONE INKJET PRINTERS MONOCHROME
    • ALL IN ONE LASER PRINTER COLOUR
    • ALL IN ONE LASER PRINTERS MONOCHROME
    • DISKPRODUSER
    • DOT MATRIX PRINTERS
    • INKJET PRINTERS COLOUR
    • INKJET PRINTERS MONOCHROME
    • LASER PRINTERS COLOUR
    • LASER PRINTERS MONOCHROME
    • OPTIONS FOR PRINTERS
    • PLOTTERS
    • SCANNERS
    • SMARTPHONE PRINTERS
  • PROJECTORS
    • CARRYING CASES
    • LAMPS PROJECTOR
    • POINTERS & ADAPTERS
    • PROJECTORS
    • WIRELESS ADAPTERS
  • SECURITY SYSTEMS
    • CCTV CAMERAS
    • DVR
      • NVR SYSTEM
    • DVR/NVR SYSTEM
    • INTELLIGENT BUILDING
    • IP CAMERAS
    • OTHER ACCESSORIES
    • SECURITY PRODUCTS
  • SERVERS
    • OPTIONS FOR SERVERS & RACKS
    • RACK SERVERS
    • TOWER SERVERS
  • SOFTWARE
    • SOFTWARE
    • SOFTWARE OPERATING SYSTEM
  • SPEAKERS, EARPHONES & HEADPHONES
    • EARPHONES & HEADPHONES
    • SPEAKERS
  • STORAGE & DRIVES
    • DVD – RW DRIVES
    • EXTERNAL HARD DISK DRIVES
    • EXTERNAL SSD DRIVES
    • NAS STORAGE
    • OPTIONS FOR STORAGE
    • SD CARDS
    • SPARE PARTS
    • TAPE DRIVES
    • USB FLASH DRIVES
  • STRUCTURE CABLING
    • CABLES
    • CONNECTORS
      • ADAPTERS
    • CONNECTORS / ADAPTERS
    • FACE PLATE
    • KEYSTONE JACK
    • PATCH CORDS
    • PATCH PANEL
    • TOOLS
  • TABLETS
    • DOCKING STATIONS & PORT REPLICATORS
    • TABLETS
  • TVs
    • HOTEL TVs
    • OPTIONS FOR TVS
    • TVs
  • VIDEO RECORDERS
    • GAMING
    • VIDEO RECORDERS – CAR CAMERAS
    • WEB CAMERAS
  • WHITE GOODS
    • BREAKFAST
    • COOKING
    • DISHWASHER
    • DRYERS
    • FREEZERS
    • HOB
    • HOOD
    • MICROWAVES
    • OPTIONS FOR HOUSEHOLD GOODS
    • OPTIONS FOR WHITEGOODS
    • OVEN
    • PERSONAL CARE
    • REFRIGERATORS
    • STEAM IRON
    • WASHING MACHINES
24/7 SUPPORT

 22 35 68 40

0 items €0.00
Menu
0 items €0.00
Browse Categories
  • MONITORS
    • 19.5″ MONITORS
    • 20-24″ MONITORS
    • 25-30″ MONITORS
    • 32-49″ MONITORS
    • LFDs DIGITAL – SIGNAGE
    • OPTIONS FOR MONITORS
  • ACCESSORIES
    • ALKALINE BATTERIES
    • BATTERIES
    • CALCULATORS
    • CARRYING CASES
    • DOCKING STATIONS & PORT REPLICATORS
    • GAMING CHAIRS
    • JOYSTICKS
    • KEYBOARD & MOUSE SETS
    • KEYBOARDS
    • MOUSE
    • OPTIONS FOR LAPTOPS
    • OPTIONS FOR PRINTERS
    • OPTIONS FOR MONITORS
    • OPTIONS FOR PCS
    • OTHER ACCESSORIES
    • PEN
    • POINTERS & ADAPTERS
    • POWER BANK
    • TV TUNERS & RADIO CARDS
  • ADAPTORS, CABLES & USB HUBS
    • ADAPTORS
    • CABLES
    • OPTIONS FOR PCS
    • OPTIONS FOR SERVERS & RACKS
    • USB HUBS
  • OTHER ACCESSORIES
  • AUDIO – VIDEO
    • SOUNDBARS
      • SPEAKERS
  • COMPONENTS FOR PCS & SERVERS
    • CONTROLLERS
    • CPUs
    • DVD – RW DRIVES
    • DVD DRIVES
    • FANS
    • GRAPHICS CARDS
    • HARD DISK DRIVES
    • INTERNAL SSD DRIVES
    • MEMORY MODULES
    • OPTIONS FOR PCS
    • OPTIONS FOR SERVERS & RACKS
    • POWER SUPPLIES
    • SD CARDS
  • CONSUMABLES
    • DATA TAPES
    • INK CARTRIDGES MULTIPACK
      • INK BOTTLES
    • INK CARTRIDGES
    • MAINTENANCE BOX
    • PAPER
    • PRINTHEADS
    • SPARE PARTS
    • TONER CARTIRDGES MULTIPACK
    • TONERS CARTRIDGES & DRUM UNITS
  • COPIERS
    • COPIERS
    • OPTIONS FOR COPIERS
  • NETWORKING & UPS
    • ANTENNAS
    • BATTERIES
    • ETHERNET CARDS
    • FIREWALL
    • INTELLIGENT BUILDING
    • IP PHONES
    • KVM SWITCH
    • LAN SWITCHES
    • OPTIONS FOR NETWORK
  • NOTEBOOKS
  • PCs
  • PHOTOGRAPHY – DIGITAL CAMERAS
  • POS SYSTEMS
  • PRINTERS & SCANNERS
  • PROJECTORS
  • SECURITY SYSTEMS
  • SERVERS
  • SOFTWARE
  • SPEAKERS, EARPHONES & HEADPHONES
  • STORAGE & DRIVES
  • UPS
  • STRUCTURE CABLING
  • TABLETS
  • TVs
  • VIDEO RECORDERS
  • Home
  • Home
  • Home
  • Shop
  • MONITORS
  • Contact us
Login / Register
0 Wishlist
0 Compare
Click to enlarge
Home NETWORKING & UPS LAN SWITCHES TP-Link JetStream 24-Port 2.5GBASE-T and 4-Port 10GE SFP+ L2+ Managed Switch with 16-Port PoE+ & 8-Port PoE++
TP-Link Omada 16-Port 2.5G and 2-Port 10GE SFP+ L2+ Managed Switch with 8-Port PoE+
TP-Link Omada 16-Port 2.5G and 2-Port 10GE SFP+ L2+ Managed Switch with 8-Port PoE+ €428.40
Back to products
TP-Link Omada 32-Port 10GE SFP+ L2+ Managed Switch
TP-Link Omada 32-Port 10GE SFP+ L2+ Managed Switch €1,142.40

TP-Link JetStream 24-Port 2.5GBASE-T and 4-Port 10GE SFP+ L2+ Managed Switch with 16-Port PoE+ & 8-Port PoE++

€928.20

8× 2.5 Gbps RJ45 PoE++, 16× 2.5 Gbps RJ45 PoE+, 4× 10G SFP+ Slots, RJ45/Micro-USB, 200 Gbps, 32 K MAC, 9 KB Jumbo, 440×330×44 mm

In stock

Compare
Add to wishlist
SKU: TL-SG3428XPP-M2 Categories: LAN SWITCHES, NETWORKING & UPS Brand: TP-LINK
TP-LINK
Share:
  • Description
  • Additional information
  • Brand
  • Shipping & Delivery
Description

Ultrafast 2.5G PoE++/PoE+ Managed Switch with 10G Uplink for Futuristic Network

2.5G PoE++/PoE+ Ports for WiFi 7/6E/6

24× 2.5 Gbps Ports Unlock the Full Potential of WiFi 7/6E/6 APs

10G Lightning-Fast Uplink Connection

4× 10 Gbps SFP+ Slots for High-Bandwidth Connectivity

PoE++/PoE+ Output

8 PoE++ and 16 PoE+ Ports with Total 500 W Power Budget.

Centralized Cloud Management

SDN Solutions Integration for a Highly Efficient Network

Unlock the Full Potential of WiFi 7/6E/6 with Multi-Gigabit PoE++/PoE+ Ports

Featuring 8x PoE++ and 16x PoE+ 2.5G ports, the switch is capable of future network expansion and deployment, providing sufficient bandwidth for incoming WiFi 7/6E/6 APs. Designed to use a single Ethernet cable for both data and power transmission, it supports up to 500 W total PoE power budget* and flexible installation to fit in various application scenarios.

Enterprise Switch with 10G Uplink

4× 10 Gbps SFP+ slots provide non-blocking switching performance and ultra-low latency, so reliable and lightning-fast connections to server and other switches are easily built.

Software Defined Networking (SDN) with Cloud Access

Omada’s Software Defined Networking (SDN) platform integrates network devices, including access points, switches and gateways, providing 100% centralized cloud management. Omada creates a highly scalable network—all controlled from a single interface. Seamless wireless and wired connections are provided, ideal for use in hospitality, education, retail, offices, and more.

Advanced L3 Features

An abundance of L2+ and L3 features are supported to help build a highly scalable and robust network, providing a reliable and efficient solution for enterprises, campuses and ISPs.

Secure Networking

Security features include IP-MAC-Port-VID Binding, Port Security, Storm Control and DHCP Snooping to defend against a range of network threats. An integrated list of common DoS attacks is available, making it easier than ever to prevent them. In addition, the Access Control Lists (ACL, L2 to L4) feature restricts access to sensitive network resources by denying packets based on source and destination MAC address, IP address, TCP/UDP ports or VLAN ID. Users’ network access can be controlled via 802.1X authentication, which works with a RADIUS/Tacacs+ server to grant access only when valid user credentials are provided.

Enterprise Level Features

A complete lineup of L2+ features are supported, including 802.1Q VLAN, Port Mirroring, STP/RSTP/MSTP, Link Aggregation Control Protocol, and 802.3x Flow Control. Advanced IGMP Snooping ensures the switch intelligently forwards multicast streams to only the appropriate subscribers, cutting out unnecessary traffic, while IGMP throttling & filtering restrict each subscriber on a port level to prevent unauthorized multicast access. Static Routing is a simple way of segmenting the network and internally routs traffic through the switch for improved efficiency.

Advanced QoS

Voice and video traffic can be prioritized based on IP address, MAC address, TCP port number, UDP port number, and more. With QoS (Quality of Service), voice and video services remain smooth, even when bandwidth is in short supply.

ISP Features

QinQ, L2PT PPPoE ID Insertion and IGMP authentication features are provided, developed with service providers in mind. 802.3ah OAM and Device Link Detection Protocol (DLDP) offer easy monitoring and troubleshooting of Ethernet links.

IPv6 Support

IPv6 functions such as Dual IPv4/IPv6 Stack, MLD Snooping, IPv6 ACL, DHCPv6 Snooping, IPv6 Interface, Path Maximum Transmission Unit (PMTU) Discovery and IPv6 Neighbor Discover guarantee your network is ready for the Next Generation Network (NGN) without upgrading your hardware.

Additional information
Switch type

Managed

Switch layer

L2+

Manufacturer

TP-LINK

Quality of Service (QoS) support

Yes

Web-based management

Yes

Cloud-managed

Yes

ARP inspection

Yes

Configuring Location Settings (CLI)

Yes

System event log

Yes

MIB support

RFC1213, RFC2233, RFC1643, RFC1493, RFC2674, RFC2819, RFC2021, RFC2620, RFC2618, RFC2925

Basic switching RJ-45 Ethernet ports quantity

24

Basic switching RJ-45 Ethernet ports type

2.5G Ethernet (100/1000/2500)

Console port

RJ-45/Micro-USB

Networking standards

IEEE 802.1D, IEEE 802.1Q, IEEE 802.1ab, IEEE 802.1p, IEEE 802.1s, IEEE 802.1w, IEEE 802.1x, IEEE 802.3, IEEE 802.3ab, IEEE 802.3ad, IEEE 802.3ae, IEEE 802.3af, IEEE 802.3at, IEEE 802.3bt, IEEE 802.3bz

10G support

Yes

Port mirroring

Yes

Flow control support

Yes

Link aggregation

Yes

Broadcast storm control

Yes

Spanning tree protocol

Yes

Head-of-line (HOL) blocking

Yes

Ethernet LAN data rates

10,100,1000,2500,10000 Mbit/s

IPv4 routes

48

IPv6 routes

48

VLAN support

Yes

Virtual LAN features

MAC address-based VLAN, Port-based VLAN, Protocol-based VLAN, Stacked VLAN, Tagged VLAN, Voice VLAN

MAC address table

32000 entries

Switching capacity

200 Gbit/s

Forwarding rate

148.8 Mpps

Store-and-forward

Yes

Static route

Yes

Jumbo frames support

Yes

Jumbo frames

9000

DHCP features

DHCP client, DHCP relay, DHCP server, DHCP snooping, DHCPv6 client, DHCPv6 snooping

Access Control List (ACL)

Yes

IGMP snooping

Yes

SSH/SSL support

Yes

Loop protection

Yes

BPDU filtering/protection

Yes

IP-MAC-Port binding

Yes

Authentication

Guest VLAN, MAC-based authentication, Port-based authentication

Authentication type

AAA, IEEE 802.1x, RADIUS, TACACS+

Multicast support

Yes

Multicast Listener Discovery (MLD) snooping

MLD v1/v2

Management protocols

SNMP v1/v2c/v3

GARP VLAN Registration Protocol (GVRP)

Yes

IPv4 & IPv6 features

IPv4/IPv6 access-control list (ACL), IPv6 ping, IPv6 portal, IPv6 tracert

Rack mounting

Yes

Form factor

1U

Product colour

Black

Internal memory

256 MB

Flash memory

32 MB

Power source

AC/PoE

Power supply included

Yes

AC input voltage

100 – 240 V

AC input frequency

50/60 Hz

Power consumption (max)

629.1 W

Power over Ethernet (PoE)

Yes

Operating temperature (T-T)

0 – 40 °C

Storage temperature (T-T)

-40 – 70 °C

Operating relative humidity (H-H)

10 – 90%

Storage relative humidity (H-H)

5 – 90%

Heat dissipation

2153.45 BTU/h

Width

440 mm

Depth

330 mm

Height

44 mm

Cables included

AC

Quick start guide

Yes

Rack mount kit

Yes

Package width

528 mm

Package depth

440 mm

Package height

100 mm

Package weight

6.1 kg

SFP+ module slots quantity

4

Rate limiting

Yes

Number of static routes

48

Packet buffer memory

16 MB

Static port security

Yes

Password protection

Yes

Queue scheduling algorithms

SP, WRR+SP, Weighted Round Robin (WRR)

LED indicators

Yes

Number of fans

3 fan(s)

Power over Ethernet plus (PoE+) ports quantity

16

Total Power over Ethernet (PoE) budget

500 W

Number of queues

8

Security algorithms

HTTPS, SSH, SSH-2, SSL/TLS

Redundant power supply (RPS) support

Yes

Full duplex

Yes

Sustainability compliance

Yes

Half duplex

Yes

Number of IP interfaces

32

Redundant fans support

Yes

Memory type

DRAM

2.5G Ethernet (copper) ports quantity

24

Compliance certificates

CE, Federal Communications Commission (FCC), RoHS

Power over Ethernet 4PPoE (PoE++) ports quantity

8

Brand

Brand

TP-LINK

Shipping & Delivery
wd-ship-1
wd-ship-2

Shipping Methods and Rates:

  • ACS Courier – 5.00 Euro. Deliver to the ACS Point. Free for orders more than 99 Euro.
  • ACS Courrier – 10.00 Euro. Delivery Door to Door within city limits. Free for orders more than 299 Euro.
  • DHL / FedEx / EMS Datapost (International Orders) – Call us 22 356840
  • Shipping Fees are assessed based on the method selected at the time of purchase. Upon Shipment, you will receive a tracking number by email, allowing you full access to shipping progress.

Related products

Placeholder
Compare

DLINK ACCESS POINT, WIRELLES AC1750 1300MPBS, 802.11ac, SIMULTANEOUS DUAL BAND PoE, CLIENT, WDS , MANAGED, 6x EXTERNAL ANTENNAS (3x4dBi 2.4GHz,3x6dBi 5GHz), 2x GLAN PORTS (1xPoE), UP TO 8 SSID/VLANs

NETWORKING & UPS, ACCESS POINTS
€99.96
DLINK ACCESS POINT, WIRELLES AC1750 1300MPBS, 802.11ac, SIMULTANEOUS DUAL BAND PoE, CLIENT, WDS , MANAGED, 6x EXTERNAL ANTENNAS (3x4dBi 2.4GHz,3x6dBi
Add to wishlist
Add to cart
Quick view
Placeholder
Compare

DLINK ADAPTER WIRELESS 11N 150 MBPS USB, INTEGRATED ANTENNA, MINI PICO

NETWORKING & UPS, WIRELESS ADAPTERS
€6.56
DLINK ADAPTER WIRELESS 11N 150 MBPS USB, INTEGRATED ANTENNA, MINI PICO
Add to wishlist
Add to cart
Quick view
Compare

DLINK ADAPTER WIRELESS G 108MBPS, PCMCIA, PRINTED ANTENNA INTERNAL CARDBUS

NETWORKING & UPS, WIRELESS ADAPTERS
€8.78
DLINK ADAPTER WIRELESS G 108MBPS, PCMCIA, PRINTED ANTENNA INTERNAL CARDBUS
Add to wishlist
Add to cart
Quick view
Placeholder
Compare

DLINK ADAPTER WIRELESS N650 RANGEBOOSTER, PCMCIA,5xINTERNAL ANTENNAS CARDBUS

NETWORKING & UPS, WIRELESS ADAPTERS
€13.17
DLINK ADAPTER WIRELESS N650 RANGEBOOSTER, PCMCIA,5xINTERNAL ANTENNAS CARDBUS
Add to wishlist
Add to cart
Quick view
Compare

DLINK ANTENNA OUTDOOR 2.4GHz, 12dBi, YAGI DIRECTIONAL, 50° HORIZONTAL, 50° VERTICAL, SURGE PROTECTION, MOUNTKIT

NETWORKING & UPS, ANTENNAS
€29.14
Directional Yagi high gain antenna
Add to wishlist
Add to cart
Quick view
Compare

DLINK CONTROLLER WIRELESS , CENTRALISED WIRELESS LAN MANAGER, MANAGE UP TO 12 ACCESS POINTS, COMPATIBLE WITH DWL-6600AP, 3600AP, 2600AP, VLAN, FIREWALL, L2/L3 ROAMING, 5YW

NETWORKING & UPS, OPTIONS FOR NETWORK
€438.60
DWC-1000 Wireless Controller, EU Plug
Add to wishlist
Add to cart
Quick view
Placeholder
Compare

DLINK MEDIA CONVERTER 1000BASE-T UTP to 1000BASE-LX SM SC GIGABIT FIBER MANAGED MC, UP TO 10KM

NETWORKING & UPS, OPTIONS FOR NETWORK
€131.65
DLINK MEDIA CONVERTER 1000BASE-T UTP to 1000BASE-LX SM SC GIGABIT FIBER MANAGED MC, UP TO 10KM
Add to wishlist
Add to cart
Quick view
Placeholder
Compare

DLINK MEDIA CONVERTER 100BASE-TX UTP to 100BASE-FX SM SC FAST ETHERNET FIBER MANAGED MC, UP TO 2KM

NETWORKING & UPS, OPTIONS FOR NETWORK
€58.43
DLINK MEDIA CONVERTER 100BASE-TX UTP to 100BASE-FX SM SC FAST ETHERNET FIBER MANAGED MC, UP TO 2KM
Add to wishlist
Add to cart
Quick view

    FREE SHIPPING

    Carrier information

    ONLINE PAYMENT

    Payment methods

    24/7 SUPPORT

    Unlimited help desk

    100% SAFE

    View our benefits

    FREE RETURNS

    Track or off orders

    • Services
      • Computer Setup
      • Computer Tune-up
      • Data Backup or Transfer
      • Data Recovery
      • Email Setup
      • Wireless Networking
    • Warranties
      • Our Warranty Policy
      • Extended Warranties
      • Operating System Install
      • Printer Setup or Troubleshoot
      • Disaster Recovery Solutions
      • Software Install & Setup
      • Technology Consultation
      • Training
      • Virtualization Solutions
      • Hardware Install
      • Hardware Repair
      • Memory Install
      • Virus & Spyware Removal
    • Customer Care
      • Terms & Conditions
      • Privacy Policy
      • Return Policy
      • Our Sitemap
      • Contact Us

    JOIN OUR NEWSLETTER:

    Will be used in accordance with our Privacy Policy

    Payment System:

    Shipping System:

    Our Social Links:

    ITLOGICPRO 2021 CREATED BY ITLOGICPRO. IT LOGICPRO SERVICES LTD
    • Menu
    • Categories
    • MONITORS
      • 19.5″ MONITORS
      • 20-24″ MONITORS
      • 25-30″ MONITORS
      • 32-49″ MONITORS
      • LFDs DIGITAL – SIGNAGE
      • OPTIONS FOR MONITORS
    • ACCESSORIES
      • ALKALINE BATTERIES
      • BATTERIES
      • CALCULATORS
      • CARRYING CASES
      • DOCKING STATIONS & PORT REPLICATORS
      • GAMING CHAIRS
      • JOYSTICKS
      • KEYBOARD & MOUSE SETS
      • KEYBOARDS
      • MOUSE
      • OPTIONS FOR LAPTOPS
      • OPTIONS FOR PRINTERS
      • OPTIONS FOR MONITORS
      • OPTIONS FOR PCS
      • OTHER ACCESSORIES
      • PEN
      • POINTERS & ADAPTERS
      • POWER BANK
      • TV TUNERS & RADIO CARDS
    • ADAPTORS, CABLES & USB HUBS
      • ADAPTORS
      • CABLES
      • OPTIONS FOR PCS
      • OPTIONS FOR SERVERS & RACKS
      • USB HUBS
    • OTHER ACCESSORIES
    • AUDIO – VIDEO
      • SOUNDBARS
        • SPEAKERS
    • COMPONENTS FOR PCS & SERVERS
      • CONTROLLERS
      • CPUs
      • DVD – RW DRIVES
      • DVD DRIVES
      • FANS
      • GRAPHICS CARDS
      • HARD DISK DRIVES
      • INTERNAL SSD DRIVES
      • MEMORY MODULES
      • OPTIONS FOR PCS
      • OPTIONS FOR SERVERS & RACKS
      • POWER SUPPLIES
      • SD CARDS
    • CONSUMABLES
      • DATA TAPES
      • INK CARTRIDGES MULTIPACK
        • INK BOTTLES
      • INK CARTRIDGES
      • MAINTENANCE BOX
      • PAPER
      • PRINTHEADS
      • SPARE PARTS
      • TONER CARTIRDGES MULTIPACK
      • TONERS CARTRIDGES & DRUM UNITS
    • COPIERS
      • COPIERS
      • OPTIONS FOR COPIERS
    • NETWORKING & UPS
      • ANTENNAS
      • BATTERIES
      • ETHERNET CARDS
      • FIREWALL
      • INTELLIGENT BUILDING
      • IP PHONES
      • KVM SWITCH
      • LAN SWITCHES
      • OPTIONS FOR NETWORK
    • NOTEBOOKS
    • PCs
    • PHOTOGRAPHY – DIGITAL CAMERAS
    • POS SYSTEMS
    • PRINTERS & SCANNERS
    • PROJECTORS
    • SECURITY SYSTEMS
    • SERVERS
    • SOFTWARE
    • SPEAKERS, EARPHONES & HEADPHONES
    • STORAGE & DRIVES
    • UPS
    • STRUCTURE CABLING
    • TABLETS
    • TVs
    • VIDEO RECORDERS
    • Home
    • Home
    • Home
    • Shop
    • MONITORS
    • Contact us
    Shopping cart
    Close
    Sign in
    Close

    Lost your password?

    No account yet?

    Create an Account